Procurando e Comparando Dados entre Duas Planilhas no Google Sheets

procv entre duas planilhas google

Se você já trabalhou com planilhas no Google Sheets, sabe como pode ser desafiador encontrar e comparar informações em grandes conjuntos de dados. Felizmente, o Google Sheets oferece uma poderosa função chamada PROCV, que permite procurar e comparar dados entre duas planilhas de forma eficiente. Neste artigo, vamos explorar como usar o PROCV entre duas planilhas no Google Sheets para simplificar suas tarefas de análise de dados.

O que é o PROCV?

Antes de mergulharmos nas funcionalidades do PROCV entre duas planilhas, é importante entender o que é essa função e como ela funciona.

Entendendo o PROCV

O PROCV, que significa “Procurar Verticalmente” (em inglês, VLOOKUP – Vertical Lookup), é uma função do Google Sheets que permite buscar um valor específico em uma coluna e retornar um valor correspondente em outra coluna. Essa função é amplamente utilizada para procurar dados em uma única planilha, mas também pode ser aplicada para comparar informações entre duas planilhas diferentes.

Usando o PROCV entre Duas Planilhas

Agora que sabemos o que é o PROCV, vamos aprender como usá-lo para buscar e comparar dados entre duas planilhas no Google Sheets.

Passo 1: Preparando suas Planilhas

Antes de iniciar, certifique-se de que suas duas planilhas estejam prontas. Abra as planilhas que deseja comparar e certifique-se de que elas tenham uma coluna comum que será usada como referência para a busca.

Passo 2: Escrevendo a Fórmula PROCV

Agora, você pode começar a escrever a fórmula PROCV na planilha onde deseja que os resultados apareçam. A sintaxe básica do PROCV é a seguinte:

=PROCV(valor_procurado, intervalo_pesquisa, índice_coluna, [correspondência])

  • valor_procurado: O valor que você deseja encontrar na outra planilha.
  • intervalo_pesquisa: A área onde o Google Sheets procurará o valor.
  • índice_coluna: O número da coluna na qual o valor correspondente deve ser encontrado.
  • correspondência: Este argumento é opcional, mas é comumente definido como “FALSO” para correspondência exata.

Passo 3: Referenciando a Outra Planilha

Para fazer o PROCV funcionar entre duas planilhas, você precisará referenciar a outra planilha no argumento “intervalo_pesquisa”. Por exemplo, se você deseja procurar um valor na planilha chamada “Planilha2” e a coluna onde deseja encontrar o valor é a coluna B, a fórmula ficaria assim:

=PROCV(A2, Planilha2!B:C, 2, FALSO)

Lembre-se de ajustar os nomes das planilhas e os números das colunas de acordo com sua situação.

Passo 4: Arrastando a Fórmula

Depois de escrever a fórmula em uma célula, você pode arrastá-la para baixo para aplicá-la a várias células, permitindo que você busque e compare vários valores de uma só vez.

Dicas Adicionais

Aqui estão algumas dicas adicionais para aprimorar sua habilidade de usar o PROCV entre duas planilhas:

1. Mantenha suas Planilhas Organizadas

Certifique-se de que suas planilhas estejam bem organizadas, com nomes de colunas claros e dados consistentes. Isso facilitará muito o uso do PROCV.

2. Use a Função PROCV com Cuidado

Embora o PROCV seja uma ferramenta poderosa, ele pode retornar resultados incorretos se não for usado corretamente. Sempre verifique suas fórmulas e os dados nas planilhas.

3. Pratique e Experimente

A melhor maneira de se tornar um especialista em usar o PROCV entre duas planilhas é praticar e experimentar com diferentes cenários. Quanto mais você usar essa função, mais familiarizado ficará com suas nuances.

Conclusão

O PROCV entre duas planilhas no Google Sheets é uma ferramenta valiosa para quem lida com análise de dados. Com a capacidade de buscar e comparar informações de maneira eficiente, você pode economizar tempo e tornar seu trabalho mais preciso. Experimente essa função em suas próprias planilhas e veja como ela pode facilitar suas tarefas diárias.

Perguntas Frequentes

1. Posso usar o PROCV para buscar dados em mais de duas planilhas?

Sim, você pode usar o PROCV para buscar dados em várias planilhas, basta referenciar as planilhas corretamente em sua fórmula.

2. O que devo fazer se o PROCV não encontrar um valor correspondente?

Nesse caso, o PROCV retornará um erro “#N/D” (Não Disponível). Você pode usar funções como “SEERRO” para lidar com esses casos.

3. Existe uma função semelhante ao PROCV no Microsoft Excel?

Sim, no Microsoft Excel, a função equivalente ao PROCV é chamada de “PROCV” também.

4. Posso usar o PROCV com texto em vez de números?

Sim, o PROCV funciona igualmente bem com texto, desde que os valores sejam compatíveis.

5. O PROCV é sensível a maiúsculas e minúsculas?

Sim, por padrão, o PROCV faz distinção entre maiúsculas e minúsculas. Se você desejar que a correspondência seja insensível a maiúsculas e minúsculas, precisará usar a função “PROCV” com a opção “FALSO” no argumento “correspondência”.

Prof. Eduardo H Gomes
Prof. Eduardo H Gomes

Mestre em Engenharia da Informação, Especialista em Engenharia da Computação, Cientista da Computação, Professor de Inteligência Artificial no IFSP, 18 anos de docência no Ensino Superior. Apaixonado por Surf, Paraglider, Mergulho livre, Tecnologia, SEO, Banco de Dados e Desenvolvimento Web.